Diary

@ssig33

12 Aug 2017 Sat 17:48

メモ: Debian stretch で terminal つきで最新の Vim をビルド

依存ライブラリ

$ sudo apt build-dep vim
$ sudo apt install libgnomeui-dev

build-dep だけだと gvim ビルドできない。 build-dep が信用できないというのはいったいどういうことなのか。

ビルドとインストール

まあふつうに。

$ ./configure --with-gnome --with-features=huge --enable-terminal  --enable-gui=gnome2 --enable-gnome-check=yes
$ make
$ sudo make install